Can someone fix my ro unit?

#1
Anyone want to troubleshoot with me? I can’t get my ro unit to work. It shows zero pressure and all of the water comes out of the waste line while noting comes out of the other side. Granted I did unplug everything and may have gotten the lines mixed up but I don’t think I did. I did have a booster pump but that stopped working well almost as soon as I started using it as it leaks now so I took it off. I can take pics to try and figure things out here or maybe someone is localish and likes to tinker with things. I could drop by and see it it’s fixable. I’m in Northborough, which is pretty much like saying I’m on the moon because it seems like everything is super far away.
 

JohnK

Well-Known Member
Staff member
Moderator
BRS Member
#2
Your flow restrictor May be the valve type. If so, the restrictor May simply be in bypass mode (valve open). Check your product line for what looks like a little ball valve. If you can find this valve, try moving it to the closed position and then see if you start to get pressure on the gauge (which would then soon be followed by product water)
 

GraniteReefer

Well-Known Member
BRS Member
#3
If you weren't so far away I would say bring it on over and we could 100% get it running. Pictures would help so I can confirm what components your model uses and hopefully see how the water is currently routed through the system to confirm it is proper. I will be going to the BRS Auction and could always bring all necessary items to fix it then if somehow it's not solved by June
 
#4
Embarrassingly it seems as though I just needed to move the valve and fix the resulting leaks. It seems to be working now. It’s supposed to be 75 gallons a day but it’s coming out in drops. I have a 25 galloncontainer im going to fill. If it isn’t full by this evening I’m guessing there’s still a problem. Maybe because the pressure never builds up? I got the booster pump because our water pressure is low but it isnt so low that it can’t build up pressure. Here are pics just in case it’s still set up wrong. The pressure was after blocking the output for a few minutes. Normally it runs lower.
 

Attachments

Chris A.

Formally toomanyfish
BRS Member
#5
That’s really low pressure. The unit won’t work right like that. Hate to tell you but you need a booster pump. Try yours again and see if it works now
 

GraniteReefer

Well-Known Member
BRS Member
#6
That inline ball valve on the waste should be closed, that is only to aid in flushing the membrane when replacing filters, the unit directly below that reads 550 is your flow restrictor and should be all that's needed, with the valve open you are allowing a path of least resistance on the membrane and cutting production. I use a 300cc restrictor too which just limits how much waste escapes thus increasing membrane pressure and potentially product water but a 550 should be fine and may be sized based on the membrane you are using.
 

JohnK

Well-Known Member
Staff member
Moderator
BRS Member
#7
Oops, I said the valve would be on the product line. Granite reefer is right, its the one on the waste line. (Dont listen to me Im posting at 5:00am)
 
#8
The pump doesn’t work at all. I tried, fumbled around with it and tried again. It never really work so I’m not surprised.
Other than making water extremely slowly, its done around 5 gallons in four hours, will low pressure effect other things? My water pressure is low but it should be coming out at something above 20 psi. We had the pressure tested by the water company and they said it met code which is 20psi. It was above that but not by much. I want to say it was 23psi. Shouldn’t the pressure at least be what comes out of the faucet? Does temperature matter? I know the outside pressure is higher so I could connect it to the outside faucet but the water temperature would be at the mercy of the weather.
 

jasonrusso

Well-Known Member
BRS Member
#9
The pump doesn’t work at all. I tried, fumbled around with it and tried again. It never really work so I’m not surprised.
Other than making water extremely slowly, its done around 5 gallons in four hours, will low pressure effect other things? My water pressure is low but it should be coming out at something above 20 psi. We had the pressure tested by the water company and they said it met code which is 20psi. It was above that but not by much. I want to say it was 23psi. Shouldn’t the pressure at least be what comes out of the faucet? Does temperature matter? I know the outside pressure is higher so I could connect it to the outside faucet but the water temperature would be at the mercy of the weather.
You want to use cold water. The higher the pressure, the better (obviously to a reasonable point, you won't want 300psi). The higher pressure allows the RO membrane to work more efficiently because you can push the water through the layers faster.
 

Sm1t7y

Member
BRS Member
#10
Anyone want to troubleshoot with me? I can’t get my ro unit to work. It shows zero pressure and all of the water comes out of the waste line while noting comes out of the other side. Granted I did unplug everything and may have gotten the lines mixed up but I don’t think I did. I did have a booster pump but that stopped working well almost as soon as I started using it as it leaks now so I took it off. I can take pics to try and figure things out here or maybe someone is localish and likes to tinker with things. I could drop by and see it it’s fixable. I’m in Northborough, which is pretty much like saying I’m on the moon because it seems like everything is super far away.




Sent from my iPhone using Tapatalk
 

rwjfish

Active Member
BRS Member
#11
hey,

If you're still in need of assistance with this, I actually work in Northborough, I am more than willing to take a look at this with you. 4 eyes are better than 2. I have the same unit, with booster pump and upgrade to 150gph (from 75).

Let me know
-Rudy
 
#12
hey,

If you're still in need of assistance with this, I actually work in Northborough, I am more than willing to take a look at this with you. 4 eyes are better than 2. I have the same unit, with booster pump and upgrade to 150gph (from 75).

Let me know
-Rudy
Thanks so much!! I bought an attachment to connect to the faucet outside where the water pressure is stronger. Hopefully this solves the problem. If not, I’ll definitely take you up on your offer!!